
<!DOCTYPE html>
<!--[if IE 8]> <html class="ie ie8" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 9]> <html class="ie ie9" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<title>EUR/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge | Forex Crunch</title>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="pingback" href="https://www.forexcrunch.com/xmlrpc.php" />
<link rel="shortcut icon" href="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2010/12/favicon.ico" />
<link rel="apple-touch-icon-precomposed" href="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2010/12/favicon.ico" />

<meta name="description" content="EUR/USD has been under pressure as virus concerns grow in Europe. The US mulling a large infrastructure plan while officials dismiss inflation, a" />
<link rel="canonical" href="https://www.forexcrunch.com/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge/" />
<link rel="publisher" href="https://plus.google.com/101790667780688710947/posts" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="EUR/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge | Forex Crunch" />
<meta property="og:description" content="EUR/USD has been under pressure as virus concerns grow in Europe. The US mulling a large infrastructure plan while officials dismiss inflation, a" />
<meta property="og:url" content="https://www.forexcrunch.com/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge/" />
<meta property="og:site_name" content="Forex Crunch" />
<meta property="article:publisher" content="https://www.facebook.com/Forex-Crunch-239940099600/" />
<meta property="article:section" content="Forex News" />
<meta property="article:published_time" content="2021-03-23T08:23:15+01:00" />
<meta property="og:image" content="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2016/01/Fotolia_87478129_S.jpg" />
<meta property="og:image:secure_url" content="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2016/01/Fotolia_87478129_S.jpg" />
<meta property="og:image:width" content="847" />
<meta property="og:image:height" content="567" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="EUR/USD has been under pressure as virus concerns grow in Europe. The US mulling a large infrastructure plan while officials dismiss inflation, a" />
<meta name="twitter:title" content="EUR/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge | Forex Crunch" />
<meta name="twitter:site" content="@forexcrunch" />
<meta name="twitter:image" content="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2016/01/Fotolia_87478129_S.jpg" />
<meta name="twitter:creator" content="@forexcrunch" />

<link rel="amphtml" href="https://www.forexcrunch.com/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge/amp/" /><meta name="generator" content="AMP for WP 1.0.76.5" /><link rel='dns-prefetch' href='//clientcdn.pushengage.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Forex Crunch &raquo; Feed" href="https://www.forexcrunch.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Forex Crunch &raquo; Comments Feed" href="https://www.forexcrunch.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Forex Crunch &raquo; EUR/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge Comments Feed" href="https://www.forexcrunch.com/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge/feed/" />

<script src="//www.googletagmanager.com/gtag/js?id=UA-1185746-1" type="text/javascript" data-cfasync="false"></script>
<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.16.2';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-1185746-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-1185746-1', {
						forceSSL:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.forexcrunch.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<link rel="stylesheet" href="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/cache/scripts/1753ef635d74319db8a9384f29c6496a.css" type="text/css" media="all" /> 
<link rel='stylesheet' id='smartmag-core-css' href='https://forexcrunch-wpengine.netdna-ssl.com/wp-content/themes/smart-mag-child/style.css?ver=2.6.1' type='text/css' media='all' />
<link rel="stylesheet" href="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/cache/scripts/d3f5f5c88ced3721e8470278b80e538c.css" type="text/css" media="all" /> 
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel="https://api.w.org/" href="https://www.forexcrunch.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.forexcrunch.com/wp-json/wp/v2/posts/231237" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.forexcrunch.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://forexcrunch-wpengine.netdna-ssl.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.forexcrunch.com/?p=231237' />
<link rel="alternate" type="application/json+oembed" href="https://www.forexcrunch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.forexcrunch.com%2Feur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.forexcrunch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.forexcrunch.com%2Feur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge%2F&#038;format=xml" />
<meta property="ia:markup_url" content="https://www.forexcrunch.com/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge/?ia_markup=1" />
<script src="https://clientcdn.pushengage.com/core/16063.js"></script>
<script>
_pe.subscribe();
</script>

<script type="application/ld+json">{"@context":"http:\/\/schema.org\/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.forexcrunch.com\/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge\/"},"url":"https:\/\/www.forexcrunch.com\/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge\/","headline":"EUR\/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge","datePublished":"2021-03-23T09:23:15+01:00","dateModified":"2021-03-23T09:23:15+01:00","publisher":{"@type":"Organization","@id":"https:\/\/www.forexcrunch.com\/#organization","name":"Forex Crunch","logo":{"@type":"ImageObject","url":"https:\/\/www.forexcrunch.com\/wp-content\/uploads\/2016\/08\/forexcrunch-logo_1.png","width":600,"height":60}},"image":{"@type":"ImageObject","url":"https:\/\/www.forexcrunch.com\/wp-content\/uploads\/2016\/01\/Fotolia_87478129_S.jpg","width":847,"height":567},"articleSection":"Forex News","description":"EUR\/USD has been under pressure as virus concerns grow in Europe. The US mulling a large infrastructure plan while officials dismiss inflation, a dollar-positive development. Tuesday's four-hour chart is showing bears have the upper hand.  \"Effectively a new pandemic\" – that is how German Chancellor Angela Merkel has described","author":{"@type":"Person","name":"Yohay Elam","url":"https:\/\/www.forexcrunch.com\/author\/admin-3\/","description":"Yohay Elam – Founder, Writer and Editor\r\nI have been into forex trading for over 5 years, and I share the experience that I have and the knowledge that I’ve accumulated. After taking a short course about forex. Like many forex traders, I’ve earned a significant share of my knowledge the hard way. Macroeconomics, the impact of news on the ever-moving currency markets and trading psychology have always fascinated me.\r\n\r\nBefore founding Forex Crunch, I’ve worked as a programmer in various hi-tech companies. I have a B. Sc. in Computer Science from Ben Gurion University. Given this background, forex software has a relatively bigger share in the posts.\r\n\r\nYohay's Google Profile","image":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/1c105436c960aeacb81d4f580c18865b?s=96&d=mm&r=g","height":96,"width":96},"sameAs":["https:\/\/www.forexcrunch.com"]}}</script>
<script async="async" type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script>

	// GPT slots
	var gptAdSlots = [];
	googletag.cmd.push(function() {



// The following mapping will only display ads when the user is on a smartphone-sized viewport.

var mapping1 = googletag.sizeMapping(). //Leaderboard mapping
		addSize([728, 0], [728, 90]). //Smarphone Landscape
		addSize([300, 0], [[320, 50], [300, 50]]). //Smartphone Portait
		addSize([0, 0], []).
		build();


		var mapping2 = googletag.sizeMapping(). // wallpaper mapping 
		addSize([1200, 0], [1597, 866]). //Desktop
		addSize([0, 0], []).
		build();


// Assigning mapping for Ad Slot 1 (LB)
		
		gptAdSlots[0] = googletag.defineSlot('/16866187/Leaderboard728x90', [728, 90], 'div-gpt-ad-1452597627604-0').   
		defineSizeMapping(mapping1).
		addService(googletag.pubads());


// Assigning mapping for Ad Slot 2 (wallpaper)

		gptAdSlots[1] = googletag.defineSlot('/16866187/Wallpaper_1597x866', [1597, 866], 'div-gpt-ad-1453126931138-0').
		defineSizeMapping(mapping2).
		addService(googletag.pubads());
    
		
  });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/16866187/Horizontal300x250', [300, 250], 'div-gpt-ad-1447926288576-0').addService(googletag.pubads());
     });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/16866187/BL_1', [100, 33], 'div-gpt-ad-1449138542534-0').addService(googletag.pubads());
    googletag.defineSlot('/16866187/BL_2', [100, 33], 'div-gpt-ad-1449138542534-1').addService(googletag.pubads());
    googletag.defineSlot('/16866187/BL_3', [100, 33], 'div-gpt-ad-1449138542534-2').addService(googletag.pubads());
    //googletag.defineSlot('/16866187/BL_4', [100, 33], 'div-gpt-ad-1449138542534-3').addService(googletag.pubads());
    //googletag.defineSlot('/16866187/BL_5', [100, 33], 'div-gpt-ad-1449138542534-4').addService(googletag.pubads());
    //googletag.defineSlot('/16866187/BL_6', [100, 33], 'div-gpt-ad-1449138542534-5').addService(googletag.pubads());
  });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/16866187/300x600', [300, 600], 'div-gpt-ad-1448298071147-0').addService(googletag.pubads());
  });
</script>
<script type='text/javascript'>
  //googletag.cmd.push(function() {
 //   googletag.defineSlot('/16866187/300x600_mobile', [300, 600], 'div-gpt-ad-1454060947752-0').addService(googletag.pubads());
 // });
</script>
<script type='text/javascript'>
  //googletag.cmd.push(function() {
  //  googletag.defineSlot('/16866187/ForexCrunch_150x150', [150, 150], 'div-gpt-ad-1448015589645-0').addService(googletag.pubads());
  //});
</script>
<script type='text/javascript'>
  //googletag.cmd.push(function() {
   //googletag.defineSlot('/16866187/BL_1_mobile', [100, 33], 'div-gpt-ad-1456308789527-0').addService(googletag.pubads());
   //googletag.defineSlot('/16866187/BL_2_mobile', [100, 33], 'div-gpt-ad-1456308887416-0').addService(googletag.pubads());
  //googletag.defineSlot('/16866187/BL_3_mobile', [100, 33], 'div-gpt-ad-1456308935001-0').addService(googletag.pubads());
     //googletag.defineSlot('/16866187/BL_4_mobile', [100, 33], 'div-gpt-ad-1456308987729-0').addService(googletag.pubads());
    //googletag.defineSlot('/16866187/BL_5_mobile', [100, 33], 'div-gpt-ad-1456309017944-0').addService(googletag.pubads());
    //googletag.defineSlot('/16866187/BL_6_mobile', [100, 33], 'div-gpt-ad-1456309048813-0').addService(googletag.pubads());
    
  //});
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/16866187/Sponsor', [300, 160], 'div-gpt-ad-1461582647220-0').addService(googletag.pubads());
  });
</script>
<script>
  googletag.cmd.push(function() {
    //googletag.defineSlot('/16866187/Lead_Gen', [810, 240], 'div-gpt-ad-1501744825137-0').addService(googletag.pubads());
    googletag.defineSlot('/16866187/Leaderboard728x90', [728, 90], 'div-gpt-ad-1452597627604-0').addService(googletag.pubads());
    
  });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/16866187/roadblock_responsive', [600, 425], 'div-gpt-ad-1452693144833-0').addService(googletag.pubads());
	googletag.defineSlot('/16866187/Brokerpromo', [310, 35], 'div-gpt-ad-1536052130018-0').addService(googletag.pubads());
    googletag.defineSlot('/16866187/Leadpromo', [300, 400], 'div-gpt-ad-1541506869475-0').addService(googletag.pubads());
    googletag.defineSlot('/16866187/Leadpromo', [300, 400], 'div-gpt-ad-1585135447267-0').addService(googletag.pubads());

    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<!--[if lt IE 9]>
<script src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/themes/smart-mag/js/html5.js" type="text/javascript"></script>
<![endif]-->
<meta property="fb:pages" content="239940099600" />
<link rel="stylesheet" type="text/css" href="/roadblock/interstitial.css" />
</head>
<body class="post-template-default single single-post postid-231237 single-format-standard page-builder right-sidebar full has-nav-dark">
<div class="main-wrap">

<div id='div-gpt-ad-1453126931138-0' style='height:866px; width:1597px;position: fixed; margin-left: -798.5px; left:50%;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1453126931138-0'); });
</script>
</div>
<div class="top-bar">
<div class="wrap">
<section class="top-bar-content cf">
<div class="trending-ticker">
<span class="heading">Latest</span>
<ul>
<li><a href="https://www.forexcrunch.com/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge/" title="EUR/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge">EUR/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge</a></li>
<li><a href="https://www.forexcrunch.com/eur-usd-set-to-fall-as-a-potential-rise-in-yields-makes-the-dollar-more-attractive/" title="EUR/USD set to fall as a potential rise in yields makes the dollar more attractive">EUR/USD set to fall as a potential rise in yields makes the dollar more attractive</a></li>
<li><a href="https://www.forexcrunch.com/usd-jpy-room-for-further-gains-where-to-target-danske/" title="USD/JPY: Room For Further Gains; Where To Target? &#8211; Danske">USD/JPY: Room For Further Gains; Where To Target? &#8211; Danske</a></li>
<li><a href="https://www.forexcrunch.com/institutional-demand-for-crypto-drops-by-60-as-uncertainty-looms-over-bitcoin-price/" title="Institutional demand for crypto drops by 60% as uncertainty looms over Bitcoin price">Institutional demand for crypto drops by 60% as uncertainty looms over Bitcoin price</a></li>
<li><a href="https://www.forexcrunch.com/aud-usd-break-below-0-7619-to-trigger-a-slide-to-the-0-7564-february-low-commerzbank/" title="AUD/USD: Break below 0.7619 to trigger a slide to the 0.7564 February low – Commerzbank">AUD/USD: Break below 0.7619 to trigger a slide to the 0.7564 February low – Commerzbank</a></li>
<li><a href="https://www.forexcrunch.com/china-recent-equity-sell-off-offers-an-opportunity-to-buy-morgan-stanley/" title="China: Recent equity sell-off offers an opportunity to buy – Morgan Stanley">China: Recent equity sell-off offers an opportunity to buy – Morgan Stanley</a></li>
<li><a href="https://www.forexcrunch.com/filecoin-price-analysis-fil-hangs-at-the-edge-of-a-cliff-while-downswing-to-58-lingers/" title="Filecoin Price Analysis: FIL hangs at the edge of a cliff, while downswing to $58 lingers">Filecoin Price Analysis: FIL hangs at the edge of a cliff, while downswing to $58 lingers</a></li>
<li><a href="https://www.forexcrunch.com/gold-price-analysis-xau-usd-to-see-selling-pressure-once-more-beyond-the-quarter-end-ocbc/" title="Gold Price Analysis: XAU/USD to see selling pressure once more beyond the quarter-end – OCBC">Gold Price Analysis: XAU/USD to see selling pressure once more beyond the quarter-end – OCBC</a></li>
</ul>
</div>
<div class="search">
<form role="search" action="https://www.forexcrunch.com/" method="get">
<input type="text" name="s" class="query live-search-query" value="" placeholder="Search..." />
<button class="search-button" type="submit"><i class="fa fa-search"></i></button>
</form>
</div> 
</section>
</div>
</div>
<div id="main-head" class="main-head">
<div class="wrap">
<header class="default">
<div class="title">
<a href="https://www.forexcrunch.com/" title="Forex Crunch" rel="home" class">
<img src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2011/01/forexcrunch.png" class="logo-image" alt="Forex Crunch" />
</a> </div>
<div class="right">
<div class="textwidget"><div id="div-gpt-ad-1452597627604-0"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1452597627604-0'); });
</script></div>
</div>
</div>
</header>
<div class="navigation-wrap cf" data-sticky-nav="1" data-sticky-type="smart">
<nav class="navigation cf nav-dark">
<div class>
<div class="mobile" data-type="classic" data-search="1">
<a href="#" class="selected">
<span class="text">Navigate</span><span class="current"></span> <i class="hamburger fa fa-bars"></i>
</a>
</div>
<div class="menu-forex-menu-container"><ul id="menu-forex-menu" class="menu"><li id="menu-item-12244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-12244"><a title="About Forex Crunch" href="https://www.forexcrunch.com/about/">About</a>
<ul class="sub-menu">
<li id="menu-item-13023" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13023"><a href="https://www.forexcrunch.com/about/">About</a></li>
<li id="menu-item-12250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12250"><a href="https://www.forexcrunch.com/the-team/">The Forex Crunch Team</a></li>
<li id="menu-item-12249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12249"><a href="https://www.forexcrunch.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-21008" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-21008"><a href="https://www.forexcrunch.com/forex-tools/">Tools</a>
<ul class="sub-menu">
<li id="menu-item-20989" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20989"><a href="https://www.forexcrunch.com/forex-tools/">Forex Tools</a></li>
<li id="menu-item-44574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44574"><a href="https://www.forexcrunch.com/tips-for-forex-traders/">Tips for Forex Traders</a></li>
<li id="menu-item-19122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-3 menu-item-19122"><a href="https://www.forexcrunch.com/category/forex-basics/">Basics</a></li>
<li id="menu-item-36252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36252"><a href="https://www.forexcrunch.com/forex-conventions/">Forex Conventions</a></li>
</ul>
</li>
<li id="menu-item-12248" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-cat-53 menu-item-12248"><a title="Forex News" href="https://www.forexcrunch.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-13021" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-53 menu-item-13021"><a href="https://www.forexcrunch.com/category/news/">Forex News</a></li>
<li id="menu-item-14045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-38 menu-item-14045"><a href="https://www.forexcrunch.com/category/opinions/">Opinions</a></li>
<li id="menu-item-13022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-1051 menu-item-13022"><a href="https://www.forexcrunch.com/category/forex-industry-2/">Forex Industry</a></li>
<li id="menu-item-13016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-1003 menu-item-13016"><a href="https://www.forexcrunch.com/category/forex-bits/">Forex Bits</a></li>
</ul>
</li>
<li id="menu-item-13007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-21 menu-item-13007"><a href="https://www.forexcrunch.com/category/daily-analysis/">Daily</a></li>
<li id="menu-item-13013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-422 menu-item-13013"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/">Weekly Forecasts</a>
<ul class="sub-menu">
<li id="menu-item-77545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77545"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/us-dollar-forecast/">Major Events Outlook</a></li>
<li id="menu-item-77542" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77542"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/eur-usd-outlook/">EUR/USD forecast</a></li>
<li id="menu-item-77543" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77543"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/gbp-usd-outlook/">GBP/USD Forecast</a></li>
<li id="menu-item-77546" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77546"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/usd-jpy-forecast/">USD/JPY Forecast</a></li>
<li id="menu-item-77544" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77544"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/aud-usd-outlook/">AUD/USD Forecast</a></li>
<li id="menu-item-77547" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77547"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/usd-cad-outlook/">USD/CAD Forecast</a></li>
</ul>
</li>
<li id="menu-item-19120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19120"><a href="https://www.forexcrunch.com/live-forex-calendar/">Live Calendar</a></li>
<li id="menu-item-66039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66039"><a href="https://www.forexcrunch.com/subscribe/">Subscribe</a></li>
</ul></div>
</div>
</nav>
</div>
</div>
</div>
<div class="breadcrumbs-wrap">
<div class="wrap">
<div class="breadcrumbs"><span class="location">You are at:</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.forexcrunch.com/"><span itemprop="title">Home</span></a></span><span class="delim">&raquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.forexcrunch.com/category/news/"><span itemprop="title">Forex News</span></a></span><span class="delim">&raquo;</span><span class="current">EUR/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge</span></div> </div>
</div>
<div class="main wrap cf">
<div class="row">
<div class="col-8 main-content">
<article id="post-231237" class="post-231237 post type-post status-publish format-standard has-post-thumbnail category-news title-above">
<header class="post-header cf">
<div class="heading cf">
<h1 class="post-title item fn" itemprop="name headline">
EUR/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge </h1>
<a href="https://www.forexcrunch.com/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge/#respond" class="comments"><i class="fa fa-comments-o"></i> 0</a>
</div>
<div class="post-meta cf">
<span class="posted-by">By
<span class="reviewer" itemprop="author"><a href="https://www.forexcrunch.com/author/admin-3/" title="Posts by Yohay Elam" rel="author">Yohay Elam</a></span>
</span>
<span class="posted-on">
<span class="dtreviewed">
Published:
<time class="value-title" datetime="2021-03-23T09:23:15+01:00" title="Mar 23, 2021 08:23" itemprop="datePublished">Mar 23, 2021 08:23 GMT | </time>
Last Modified:
<time class="value-title" datetime="2021-03-23T09:23:15+01:00" title="Mar 23, 2021 09:23" itemprop="dateModified">Mar 23, 2021 09:23 GMT</time>
</span>
</span>
<span class="cats"><a href="https://www.forexcrunch.com/category/news/" rel="category tag">Forex News</a></span>
</div>
</header>
<div class="post-container cf">
<div class="post-content-right">

<div id='div-gpt-ad-1447926288576-0' style='height:250px; width:300px;float:left; margin: 20px; position:relative;z-index:1;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1447926288576-0'); });
</script>
</div>
<div class="post-content description " itemprop="articleBody">
<ul>
<li><strong>EUR/USD has been under pressure as virus concerns grow in Europe.</strong></li>
<li><strong>The US mulling a large infrastructure plan while officials dismiss inflation, a dollar-positive development.</strong></li>
<li><strong>Tuesday&#8217;s four-hour chart is showing bears have the upper hand. </strong></li>
</ul>
<p>&#8220;<strong>Effectively a new pandemic</strong>&#8221; – that is how German Chancellor Angela Merkel has described the spread of the British variant in Europe&#8217;s largest country. The B 1.1.7 strain had already wreaked havoc in several other countries and has now brought Berlin to announce a strict lockdown around Easter, and an extension to other measures through April 18.</p>
<p>Europe&#8217;s economic &#8220;locomotive&#8221; is now derailed while most of France and Italy are also under more severe restrictions, delaying the recovery. Moreover, <strong>vaccinations remain sluggish</strong> despite an improving political climate The British government is trying to calm EU officials with overtures regarding the distribution of AstraZeneca&#8217;s doses. UK Prime Minister Boris Johnson&#8217;s moves come after Brussels threatened an export ban.</p>
<p>However, hopes that <strong>Astra&#8217;s immunization solution has received a dose of calm have been shattered again</strong>. One day after the embattled pharmaceutical firm reported a successful Phase 3 trial in the <a href="https://www.fxstreet.com/economic-calendar/united-states" data-cke-saved-href="https://www.fxstreet.com/economic-calendar/united-states">US</a>, authorities in Washington released a statement expressing concern about some of the data submitted by the company, saying it is outdated.</p>
<p>The <strong>damage to AstraZeneca&#8217;s reputation has already been done</strong>, with more Europeans set to reject the jabs. On this background, it would be hard for the euro to recover.</p>
<p>On the other side of the Atlantic, President Joe Biden&#8217;s administration is set to present <strong>infrastructure spending plans worth around $3 trillion</strong> – on top of the covid relief plan worth $1.9 trillion that is being deployed. Additional spending means a hotter economy and also elevated debt issuance – and a potential rise in yields makes the dollar more attractive.</p>
<p>Treasury Secretary <strong>Janet Yellen and Federal Reserve Chair <a href="https://www.fxstreet.com/macroeconomics/central-banks/fed" data-cke-saved-href="https://www.fxstreet.com/macroeconomics/central-banks/fed">Jerome Powell</a></strong> are slated to appear before Congress later in the day and discuss efforts to support the economy in the crisis. Powell&#8217;s prepared remarks were already released and they echo last week&#8217;s rate decision.</p>
<p>The Fed will continue supporting the economy, seeing through temporary inflation rises and the unemployment rate, which understates real labor conditions. Republican lawmakers are set to raise inflation concerns.</p>
<p><a href="https://www.fxstreet.com/analysis/fed-chairman-powell-cares-testimony-mums-the-word-on-higher-rates-202103230232" target="_blank" rel="noreferrer noopener" data-qa="message_attachment_title_link" data-cke-saved-href="https://www.fxstreet.com/analysis/fed-chairman-powell-cares-testimony-mums-the-word-on-higher-rates-202103230232">Fed Chairman Powell CARES Testimony: Mums the word on higher rates</a></p>
<p>US <strong>New Home Sales</strong> figures for February will probably show ongoing high demand in the construction sector, similar to Existing Home Sales statistics, while Powell&#8217;s colleagues at the FOMC will probably reiterate the Fed&#8217;s recent messages.</p>
<p><strong>All in all, there is room for yields to resume their gains and the dollar to rise. </strong></p>
<h2 class="fxs_headline_medium">EUR/USD Technical Analysis</h2>
<p><a href="https://editorial.fxstreet.com/miscelaneous/f1tg78Nt8cKAuwa32Bjz9rG1TXY2d04olNXN7tGY/EUR_USD%20-%202021-03-23T091002.263-637520838076876489.png" target="_blank" rel="noopener" data-cke-saved-href="https://editorial.fxstreet.com/miscelaneous/f1tg78Nt8cKAuwa32Bjz9rG1TXY2d04olNXN7tGY/EUR_USD%20-%202021-03-23T091002.263-637520838076876489.png"><img src="https://editorial.fxstreet.com/miscelaneous/f1tg78Nt8cKAuwa32Bjz9rG1TXY2d04olNXN7tGY/EUR_USD%20-%202021-03-23T091002.263-637520838076876489.png" data-cke-saved-src="https://editorial.fxstreet.com/miscelaneous/f1tg78Nt8cKAuwa32Bjz9rG1TXY2d04olNXN7tGY/EUR_USD%20-%202021-03-23T091002.263-637520838076876489.png" /></a></p>
<p>Euro/dollar has slipped back below the 50 Simple Moving Average on the four-hour <a href="https://www.fxstreet.com/rates-charts/chart" data-cke-saved-href="https://www.fxstreet.com/rates-charts/chart">chart</a> and momentum has turned to the downside once again – both bearish developments.</p>
<p>Some support awaits at the weekly low of 1.1875, followed by the all-important 2021 trough of 1.1836. Further down, 1.18 and 1.1750 come into play.</p>
<p>The round 1.19 level serves as a battle line, and more significant resistance is at 1.1950. The double-top at 1.1990 is critical for any upside move.</p>
<p><a href="https://www.fxstreet.com/analysis/eur-usd-price-forecast-2021-euro-dollar-long-term-bullish-breakout-points-to-12750-202012231132" target="_blank" rel="noopener" data-cke-saved-href="https://www.fxstreet.com/analysis/eur-usd-price-forecast-2021-euro-dollar-long-term-bullish-breakout-points-to-12750-202012231132">EUR/USD Price Forecast 2021: Euro-dollar long-term bullish breakout points to 1.2750</a></p>
<a data-sumome-listbuilder-id="6d1d114d-150b-4330-9a4e-fa2b436a5859">Get the 5 most predictable currency pairs</a>
</div>
</div>
</div>
</article>
<section class="navigate-posts">
<div class="previous"><span class="main-color title"><i class="fa fa-chevron-left"></i> Previous Article</span><span class="link"><a href="https://www.forexcrunch.com/eur-usd-set-to-fall-as-a-potential-rise-in-yields-makes-the-dollar-more-attractive/" rel="prev">EUR/USD set to fall as a potential rise in yields makes the dollar more attractive</a></span> </div>
<div class="next"> </div>
</section>
<h3 class="section-head">About Author</h3>
<section class="author-info">
<img alt='' src='https://secure.gravatar.com/avatar/1c105436c960aeacb81d4f580c18865b?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1c105436c960aeacb81d4f580c18865b?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy' />
<div class="description">
<a href="https://www.forexcrunch.com/author/admin-3/" title="Posts by Yohay Elam" rel="author">Yohay Elam</a>
<ul class="social-icons">
<li>
<a href="https://www.forexcrunch.com" class="icon fa fa-home" title="Website">
<span class="visuallyhidden">Website</span></a>
</li>
</ul>
<p class="bio"><strong>Yohay Elam – Founder, Writer and Editor</strong>
I have been into forex trading for over 5 years, and I share the experience that I have and the knowledge that I’ve accumulated. After taking a short course about forex. Like many forex traders, I’ve earned a significant share of my knowledge the hard way. Macroeconomics, the impact of news on the ever-moving currency markets and trading psychology have always fascinated me.
Before founding Forex Crunch, I’ve worked as a programmer in various hi-tech companies. I have a B. Sc. in Computer Science from Ben Gurion University. Given this background, forex software has a relatively bigger share in the posts.
<a href="https://plus.google.com/u/1/112509878330587949772/about" rel="author">Yohay's Google Profile</a></p>
</div>
</section>
<div class="comments">
<div id="disqus_thread"></div>
</div>
</div>
<aside class="col-4 sidebar">
<ul>
<li id="text-506661927" class="widget widget_text"> <div class="textwidget">

<div id='div-gpt-ad-1461582647220-0' style='height:160px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1461582647220-0'); });
</script>
</div>
</div>
</li>
<li id="text-506661920" class="widget widget_text"> <div class="textwidget"><p><br />
</p>
<div id="div-gpt-ad-1448298071147-0" style="height: 600px; width: 300px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1448298071147-0'); });
</script></div>
<p>&nbsp;</p>
<h3>Top Brokers</h3>
<p></p>
<div id="div-gpt-ad-1536052130018-0" style="height: 35px; width: 310px;"><script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1536052130018-0'); });
</script></div>
<p></p>
<div id="div-gpt-ad-1541506869475-0" style="height: 400px; width: 300px;"><script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1541506869475-0'); });
</script></div>
<p><br />
<br />
</p>
<div id="div-gpt-ad-1449138542534-1" style="height: 33px; width: 100px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1449138542534-1'); });
</script></div>
<p></p>
<div id="div-gpt-ad-1449138542534-2" style="height: 33px; width: 100px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1449138542534-2'); });
</script></div>
<p></p>
<div id="div-gpt-ad-1449138542534-3" style="height: 33px; width: 100px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1449138542534-3'); });
</script></div>
<p></p>
<div id="div-gpt-ad-1449138542534-4" style="height: 33px; width: 100px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1449138542534-4'); });
</script></div>
<p></p>
<div id="div-gpt-ad-1449138542534-5" style="height: 33px; width: 100px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1449138542534-5'); });
</script></div>
<p>&nbsp;</p>
<div id="FJ-voice-news-player" style="width:300px"></div>
<p><br />
<script type='text/javascript'>
    (function () {
        var jo = document.createElement('script');
        jo.type = 'text/javascript';
        jo.id = 'FJVoiceFeed';
        var r = Math.floor(Math.random() * (9999 - 0 + 1) + 0);
        jo.src = 'https://www.financialjuice.com/widgets/voice-player.js?mode=inline&display=1&container=FJ-voice-news-player&info=forexcrunch&r=' + r;
        document.getElementsByTagName('head')[0].appendChild(jo);
    })();
</script></p>
</div>
</li>
<li id="text-506661919" class="widget widget_text"><h3 class="widgettitle">About ForexCrunch</h3> <div class="textwidget"><p>Forex Crunch is a site all about the foreign exchange market, which consists of news, opinions, daily and weekly forex analysis, technical analysis, tutorials, basics of the forex market, forex software posts, insights about the forex industry and whatever is related to Forex.</p>
<p><a href="https://www.forexcrunch.com/about/">Read More</a></p>
</div>
</li>
<li id="text-506661921" class="widget widget_text"><h3 class="widgettitle">Follow us</h3> <div class="textwidget"><div id="FJ-voice-news-player" style="width:300px"></div>

<script type='text/javascript'>
    (function () {
        var jo = document.createElement('script');
        jo.type = 'text/javascript';
        jo.id = 'FJVoiceFeed';
        var r = Math.floor(Math.random() * (9999 - 0 + 1) + 0);
        jo.src = 'https://www.financialjuice.com/widgets/voice-player.js?mode=inline&display=1&container=FJ-voice-news-player&info=forexcrunch&r=' + r;
        document.getElementsByTagName('head')[0].appendChild(jo);
    })();
</script>
<div><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-facebook nolightbox" data-provider="facebook" target="_blank" rel="nofollow noopener" title="Follow us on Facebook" href="https://www.facebook.com/Forex-Crunch-239940099600/" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:21px;margin-right:21px;"><img alt="Facebook" title="Follow us on Facebook" class="synved-share-image synved-social-image synved-social-image-follow" width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/facebook.png" /></a><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-twitter nolightbox" data-provider="twitter" target="_blank" rel="nofollow noopener" title="Follow us on Twitter" href="https://twitter.com/forexcrunch" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:21px;margin-right:21px;"><img alt="twitter" title="Follow us on Twitter" class="synved-share-image synved-social-image synved-social-image-follow" width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/twitter.png" /></a><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-google_plus nolightbox" data-provider="google_plus" target="_blank" rel="nofollow noopener" title="Follow us on Google+" href="https://plus.google.com/101790667780688710947/posts" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:21px;margin-right:21px;"><img alt="google_plus" title="Follow us on Google+" class="synved-share-image synved-social-image synved-social-image-follow" width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/google_plus.png" /></a><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-mail nolightbox" data-provider="mail" rel="nofollow" title="Contact Us" href="https://www.forexcrunch.com/contact-us/" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:21px;"><img alt="mail" title="Contact Us" class="synved-share-image synved-social-image synved-social-image-follow" width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/mail.png" /></a></div>
<a href="http://www.financialjuice.com/company/Forex%20Crunch" rel="nofollow noopener" target="_blank"><img src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2016/05/FinancialJuice.png"></a>
<br />

<div id='div-gpt-ad-1448015589645-0' style='height:150px; width:150px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1448015589645-0'); });
</script>
</div>
</div>
</li>
</ul>
</aside>
</div> 
</div> 
<footer class="main-footer">
<div class="wrap">
<ul class="widgets row cf">
<li class="widget col-4 widget_nav_menu"><h3 class="widgettitle">Useful Links</h3><div class="menu-useful-links-container"><ul id="menu-useful-links" class="menu"><li id="menu-item-65795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65795"><a href="https://www.forexcrunch.com/about/">About</a></li>
<li id="menu-item-65796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65796"><a href="https://www.forexcrunch.com/the-team/">The Forex Crunch Team</a></li>
<li id="menu-item-65797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65797"><a href="https://www.forexcrunch.com/contact-us/">Contact Us</a></li>
<li id="menu-item-65798" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65798"><a href="https://www.forexcrunch.com/advertising-on-forex-crunch/">Advertising</a></li>
<li id="menu-item-65800" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65800"><a href="https://www.forexcrunch.com/forex-tools/">Forex Tools</a></li>
</ul></div></li>
<li class="widget col-4 widget_recent_entries">
<h3 class="widgettitle">Recent Updates</h3>
<ul>
<li>
<a href="https://www.forexcrunch.com/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge/" aria-current="page">EUR/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge</a>
</li>
<li>
<a href="https://www.forexcrunch.com/eur-usd-set-to-fall-as-a-potential-rise-in-yields-makes-the-dollar-more-attractive/">EUR/USD set to fall as a potential rise in yields makes the dollar more attractive</a>
</li>
<li>
<a href="https://www.forexcrunch.com/usd-jpy-room-for-further-gains-where-to-target-danske/">USD/JPY: Room For Further Gains; Where To Target? &#8211; Danske</a>
</li>
<li>
<a href="https://www.forexcrunch.com/institutional-demand-for-crypto-drops-by-60-as-uncertainty-looms-over-bitcoin-price/">Institutional demand for crypto drops by 60% as uncertainty looms over Bitcoin price</a>
</li>
<li>
<a href="https://www.forexcrunch.com/aud-usd-break-below-0-7619-to-trigger-a-slide-to-the-0-7564-february-low-commerzbank/">AUD/USD: Break below 0.7619 to trigger a slide to the 0.7564 February low – Commerzbank</a>
</li>
</ul>
</li><li class="widget col-4 widget_text"><h3 class="widgettitle">Disclaimer</h3> <div class="textwidget"><p style="font-size: 10px">Foreign exchange (Forex) trading carries a high level of risk and may not be suitable for all investors. The risk grows as the leverage is higher. Investment objectives, risk appetite and the trader's level of experience should be carefully weighed before entering the Forex market. There is always a possibility of losing some or all of your initial investment / deposit, so you should not invest money which you cannot afford to lose. The high risk that is involved with currency trading must be known to you. Please ask for advice from an independent financial advisor before entering this market. Any comments made on Forex Crunch or on other sites that have received permission to republish the content originating on Forex Crunch reflect the opinions of the individual authors and do not necessarily represent the opinions of any of Forex Crunch's authorized authors. Forex Crunch has not verified the accuracy or basis-in-fact of any claim or statement made by any independent author: Omissions and errors may occur. Any news, analysis, opinion, price quote or any other information contained on Forex Crunch and permitted re-published content should be taken as general market commentary. This is by no means investment advice. Forex Crunch will not accept liability for any damage, loss, including without limitation to, any profit or loss, which may either arise directly or indirectly from use of such information. </p></div>
</li> </ul>
</div>
<div class="lower-foot">
<div class="wrap">
</div>
</div>
</footer>
</div> 
<script type='text/javascript'>
/* <![CDATA[ */
/* monsterinsights-frontend-script */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"pdf,doc,ppt,xls,zip,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.forexcrunch.com","hash_tracking":"false","ua":"UA-1185746-1"};
/* disqus_count */
var countVars = {"disqusShortname":"forexcrunch"};
/* disqus_embed */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"231237 https:\/\/www.forexcrunch.com\/?p=231237","disqusShortname":"forexcrunch","disqusTitle":"EUR\/USD: Clouds darkening over euro, Powell and Yellen may push it over the edge","disqusUrl":"https:\/\/www.forexcrunch.com\/eur-usd-clouds-darkening-over-euro-powell-and-yellen-may-push-it-over-the-edge\/","postId":"231237"};
/* bunyad-theme */
var Bunyad = {"ajaxurl":"https:\/\/www.forexcrunch.com\/wp-admin\/admin-ajax.php"};

/* ]]> */
</script>
<script type="text/javascript" src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/cache/scripts/3530aa372b79c796a5b81213cc2c7f19-minify.js">/*Cache!*/</script>
<script type="text/javascript" src="/roadblock/interstitial.js">

/***********************************************
* Interstitial Content Box- (c) Dynamic Drive DHTML code library (www.dynamicdrive.com)
* Please keep this notice intact
* Visit Dynamic Drive at http://www.dynamicdrive.com/ for full source code
***********************************************/

</script>
</body>
</html>