
<!DOCTYPE html>
<!--[if IE 8]> <html class="ie ie8" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 9]> <html class="ie ie9" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<title>GBP/USD suffers altitude sickness, new Powell-powered rally may wait | Forex Crunch</title>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="pingback" href="https://www.forexcrunch.com/xmlrpc.php" />
<link rel="shortcut icon" href="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2010/12/favicon.ico" />
<link rel="apple-touch-icon-precomposed" href="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2010/12/favicon.ico" />

<meta name="description" content="GBP/USD has tumbled over 100 pips from the highs after a massive rally.  Fed Chair Powell´s dovishness and the UK´s exit plan may trigger a new upward" />
<link rel="canonical" href="https://www.fxstreet.com/analysis/gbp-usd-forecast-sterling-suffers-altitude-sickness-new-powell-powered-rally-may-wait-202102241201" />
<link rel="publisher" href="https://plus.google.com/101790667780688710947/posts" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="GBP/USD suffers altitude sickness, new Powell-powered rally may wait | Forex Crunch" />
<meta property="og:description" content="GBP/USD has tumbled over 100 pips from the highs after a massive rally.  Fed Chair Powell´s dovishness and the UK´s exit plan may trigger a new upward" />
<meta property="og:url" content="https://www.fxstreet.com/analysis/gbp-usd-forecast-sterling-suffers-altitude-sickness-new-powell-powered-rally-may-wait-202102241201" />
<meta property="og:site_name" content="Forex Crunch" />
<meta property="article:publisher" content="https://www.facebook.com/Forex-Crunch-239940099600/" />
<meta property="article:section" content="Forex News" />
<meta property="article:published_time" content="2021-02-24T12:08:59+01:00" />
<meta property="og:image" content="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2011/12/Fotolia_7605051_XS.jpg" />
<meta property="og:image:secure_url" content="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2011/12/Fotolia_7605051_XS.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="300" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="GBP/USD has tumbled over 100 pips from the highs after a massive rally.  Fed Chair Powell´s dovishness and the UK´s exit plan may trigger a new upward" />
<meta name="twitter:title" content="GBP/USD suffers altitude sickness, new Powell-powered rally may wait | Forex Crunch" />
<meta name="twitter:site" content="@forexcrunch" />
<meta name="twitter:image" content="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2011/12/Fotolia_7605051_XS.jpg" />
<meta name="twitter:creator" content="@forexcrunch" />

<link rel="amphtml" href="https://www.forexcrunch.com/gbp-usd-suffers-altitude-sickness-new-powell-powered-rally-may-wait/amp/" /><meta name="generator" content="AMP for WP 1.0.76" /><link rel='dns-prefetch' href='//clientcdn.pushengage.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Forex Crunch &raquo; Feed" href="https://www.forexcrunch.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Forex Crunch &raquo; Comments Feed" href="https://www.forexcrunch.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Forex Crunch &raquo; GBP/USD suffers altitude sickness, new Powell-powered rally may wait Comments Feed" href="https://www.forexcrunch.com/gbp-usd-suffers-altitude-sickness-new-powell-powered-rally-may-wait/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.forexcrunch.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<link rel="stylesheet" href="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/cache/scripts/6a412f9743f0a2ddb48e200d455cb31e.css" type="text/css" media="all" /> 
<link rel='stylesheet' id='smartmag-core-css' href='https://forexcrunch-wpengine.netdna-ssl.com/wp-content/themes/smart-mag-child/style.css?ver=2.6.1' type='text/css' media='all' />
<link rel="stylesheet" href="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/cache/scripts/d3f5f5c88ced3721e8470278b80e538c.css" type="text/css" media="all" /> 
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='https://api.w.org/' href='https://www.forexcrunch.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.forexcrunch.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://forexcrunch-wpengine.netdna-ssl.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.forexcrunch.com/?p=228305' />
<link rel="alternate" type="application/json+oembed" href="https://www.forexcrunch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.forexcrunch.com%2Fgbp-usd-suffers-altitude-sickness-new-powell-powered-rally-may-wait%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.forexcrunch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.forexcrunch.com%2Fgbp-usd-suffers-altitude-sickness-new-powell-powered-rally-may-wait%2F&#038;format=xml" />
<meta property="ia:markup_url" content="https://www.forexcrunch.com/gbp-usd-suffers-altitude-sickness-new-powell-powered-rally-may-wait/?ia_markup=1" />
<script src="https://clientcdn.pushengage.com/core/16063.js"></script>
<script>
_pe.subscribe();
</script>

<script type="application/ld+json">{"@context":"http:\/\/schema.org\/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.forexcrunch.com\/gbp-usd-suffers-altitude-sickness-new-powell-powered-rally-may-wait\/"},"url":"https:\/\/www.forexcrunch.com\/gbp-usd-suffers-altitude-sickness-new-powell-powered-rally-may-wait\/","headline":"GBP\/USD suffers altitude sickness, new Powell-powered rally may...","datePublished":"2021-02-24T13:08:59+01:00","dateModified":"2021-02-24T13:08:59+01:00","publisher":{"@type":"Organization","@id":"https:\/\/www.forexcrunch.com\/#organization","name":"Forex Crunch","logo":{"@type":"ImageObject","url":"https:\/\/www.forexcrunch.com\/wp-content\/uploads\/2016\/08\/forexcrunch-logo_1.png","width":600,"height":60}},"image":{"@type":"ImageObject","url":"https:\/\/www.forexcrunch.com\/wp-content\/uploads\/2011\/12\/Fotolia_7605051_XS.jpg","width":696,"height":300},"articleSection":"Forex News","description":"GBP\/USD has tumbled over 100 pips from the highs after a massive rally.  Fed Chair Powell´s dovishness and the UK´s exit plan may trigger a new upward move after the correction ends. Wednesday's four-hour chart is showing the currency pair is still suffering from overbought conditions. Overheating requires a","author":{"@type":"Person","name":"Yohay Elam","url":"https:\/\/www.forexcrunch.com\/author\/admin-3\/","description":"Yohay Elam – Founder, Writer and Editor\r\nI have been into forex trading for over 5 years, and I share the experience that I have and the knowledge that I’ve accumulated. After taking a short course about forex. Like many forex traders, I’ve earned a significant share of my knowledge the hard way. Macroeconomics, the impact of news on the ever-moving currency markets and trading psychology have always fascinated me.\r\n\r\nBefore founding Forex Crunch, I’ve worked as a programmer in various hi-tech companies. I have a B. Sc. in Computer Science from Ben Gurion University. Given this background, forex software has a relatively bigger share in the posts.\r\n\r\nYohay's Google Profile","image":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/1c105436c960aeacb81d4f580c18865b?s=96&d=mm&r=g","height":96,"width":96},"sameAs":["https:\/\/www.forexcrunch.com"]}}</script>
<script async="async" type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script>

	// GPT slots
	var gptAdSlots = [];
	googletag.cmd.push(function() {



// The following mapping will only display ads when the user is on a smartphone-sized viewport.

var mapping1 = googletag.sizeMapping(). //Leaderboard mapping
		addSize([728, 0], [728, 90]). //Smarphone Landscape
		addSize([300, 0], [[320, 50], [300, 50]]). //Smartphone Portait
		addSize([0, 0], []).
		build();


		var mapping2 = googletag.sizeMapping(). // wallpaper mapping 
		addSize([1200, 0], [1597, 866]). //Desktop
		addSize([0, 0], []).
		build();


// Assigning mapping for Ad Slot 1 (LB)
		
		gptAdSlots[0] = googletag.defineSlot('/16866187/Leaderboard728x90', [728, 90], 'div-gpt-ad-1452597627604-0').   
		defineSizeMapping(mapping1).
		addService(googletag.pubads());


// Assigning mapping for Ad Slot 2 (wallpaper)

		gptAdSlots[1] = googletag.defineSlot('/16866187/Wallpaper_1597x866', [1597, 866], 'div-gpt-ad-1453126931138-0').
		defineSizeMapping(mapping2).
		addService(googletag.pubads());
    
		
  });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/16866187/Horizontal300x250', [300, 250], 'div-gpt-ad-1447926288576-0').addService(googletag.pubads());
     });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/16866187/BL_1', [100, 33], 'div-gpt-ad-1449138542534-0').addService(googletag.pubads());
    googletag.defineSlot('/16866187/BL_2', [100, 33], 'div-gpt-ad-1449138542534-1').addService(googletag.pubads());
    googletag.defineSlot('/16866187/BL_3', [100, 33], 'div-gpt-ad-1449138542534-2').addService(googletag.pubads());
    //googletag.defineSlot('/16866187/BL_4', [100, 33], 'div-gpt-ad-1449138542534-3').addService(googletag.pubads());
    //googletag.defineSlot('/16866187/BL_5', [100, 33], 'div-gpt-ad-1449138542534-4').addService(googletag.pubads());
    //googletag.defineSlot('/16866187/BL_6', [100, 33], 'div-gpt-ad-1449138542534-5').addService(googletag.pubads());
  });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/16866187/300x600', [300, 600], 'div-gpt-ad-1448298071147-0').addService(googletag.pubads());
  });
</script>
<script type='text/javascript'>
  //googletag.cmd.push(function() {
 //   googletag.defineSlot('/16866187/300x600_mobile', [300, 600], 'div-gpt-ad-1454060947752-0').addService(googletag.pubads());
 // });
</script>
<script type='text/javascript'>
  //googletag.cmd.push(function() {
  //  googletag.defineSlot('/16866187/ForexCrunch_150x150', [150, 150], 'div-gpt-ad-1448015589645-0').addService(googletag.pubads());
  //});
</script>
<script type='text/javascript'>
  //googletag.cmd.push(function() {
   //googletag.defineSlot('/16866187/BL_1_mobile', [100, 33], 'div-gpt-ad-1456308789527-0').addService(googletag.pubads());
   //googletag.defineSlot('/16866187/BL_2_mobile', [100, 33], 'div-gpt-ad-1456308887416-0').addService(googletag.pubads());
  //googletag.defineSlot('/16866187/BL_3_mobile', [100, 33], 'div-gpt-ad-1456308935001-0').addService(googletag.pubads());
     //googletag.defineSlot('/16866187/BL_4_mobile', [100, 33], 'div-gpt-ad-1456308987729-0').addService(googletag.pubads());
    //googletag.defineSlot('/16866187/BL_5_mobile', [100, 33], 'div-gpt-ad-1456309017944-0').addService(googletag.pubads());
    //googletag.defineSlot('/16866187/BL_6_mobile', [100, 33], 'div-gpt-ad-1456309048813-0').addService(googletag.pubads());
    
  //});
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/16866187/Sponsor', [300, 160], 'div-gpt-ad-1461582647220-0').addService(googletag.pubads());
  });
</script>
<script>
  googletag.cmd.push(function() {
    //googletag.defineSlot('/16866187/Lead_Gen', [810, 240], 'div-gpt-ad-1501744825137-0').addService(googletag.pubads());
    googletag.defineSlot('/16866187/Leaderboard728x90', [728, 90], 'div-gpt-ad-1452597627604-0').addService(googletag.pubads());
    
  });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/16866187/roadblock_responsive', [600, 425], 'div-gpt-ad-1452693144833-0').addService(googletag.pubads());
	googletag.defineSlot('/16866187/Brokerpromo', [310, 35], 'div-gpt-ad-1536052130018-0').addService(googletag.pubads());
    googletag.defineSlot('/16866187/Leadpromo', [300, 400], 'div-gpt-ad-1541506869475-0').addService(googletag.pubads());
    googletag.defineSlot('/16866187/Leadpromo', [300, 400], 'div-gpt-ad-1585135447267-0').addService(googletag.pubads());

    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<!--[if lt IE 9]>
<script src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/themes/smart-mag/js/html5.js" type="text/javascript"></script>
<![endif]-->
<meta property="fb:pages" content="239940099600" />
<link rel="stylesheet" type="text/css" href="/roadblock/interstitial.css" />
</head>
<body class="post-template-default single single-post postid-228305 single-format-standard page-builder right-sidebar full has-nav-dark">
<div class="main-wrap">

<div id='div-gpt-ad-1453126931138-0' style='height:866px; width:1597px;position: fixed; margin-left: -798.5px; left:50%;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1453126931138-0'); });
</script>
</div>
<div class="top-bar">
<div class="wrap">
<section class="top-bar-content cf">
<div class="trending-ticker">
<span class="heading">Latest</span>
<ul>
<li><a href="https://www.forexcrunch.com/chainlink-price-prediction-link-remains-bullish-despite-short-term-sell-off-as-whales-hold-strong/" title="Chainlink Price Prediction: LINK remains bullish despite short-term sell-off as whales hold strong">Chainlink Price Prediction: LINK remains bullish despite short-term sell-off as whales hold strong</a></li>
<li><a href="https://www.forexcrunch.com/fomc-chairman-jerome-powell-testimony-before-house-committee-on-financial-services-live-stream/" title="FOMC Chairman Jerome Powell testimony before House Committee on Financial Services – live stream">FOMC Chairman Jerome Powell testimony before House Committee on Financial Services – live stream</a></li>
<li><a href="https://www.forexcrunch.com/boes-broadbent-sterling-appreciation-to-have-some-depressive-effect-on-inflation/" title="BoE&#8217;s Broadbent: Sterling appreciation to have some depressive effect on inflation">BoE&#8217;s Broadbent: Sterling appreciation to have some depressive effect on inflation</a></li>
<li><a href="https://www.forexcrunch.com/boes-bailey-eu-locality-policy-for-financial-services-is-controversial/" title="BoE&#8217;s Bailey: EU locality policy for financial services is controversial">BoE&#8217;s Bailey: EU locality policy for financial services is controversial</a></li>
<li><a href="https://www.forexcrunch.com/gold-price-analysis-break-below-1760-to-leave-xau-usd-under-pressure-commerzbank/" title="Gold Price Analysis: Break below $1760 to leave XAU/USD under pressure – Commerzbank">Gold Price Analysis: Break below $1760 to leave XAU/USD under pressure – Commerzbank</a></li>
<li><a href="https://www.forexcrunch.com/boes-haskel-risks-to-activity-very-much-on-downside/" title="BoE&#8217;s Haskel: Risks to activity very much on downside">BoE&#8217;s Haskel: Risks to activity very much on downside</a></li>
<li><a href="https://www.forexcrunch.com/silver-slips-back-below-27-50-mark-pressured-as-us-bond-yield-rally-kicks-into-overdrive/" title="Silver slips back below $27.50 mark, pressured as US bond yield rally kicks into overdrive">Silver slips back below $27.50 mark, pressured as US bond yield rally kicks into overdrive</a></li>
<li><a href="https://www.forexcrunch.com/sp-500-index-fails-to-build-on-tuesdays-rebound-opens-modestly-lower/" title="S&amp;P 500 Index fails to build on Tuesday&#8217;s rebound, opens modestly lower">S&amp;P 500 Index fails to build on Tuesday&#8217;s rebound, opens modestly lower</a></li>
</ul>
</div>
<div class="search">
<form role="search" action="https://www.forexcrunch.com/" method="get">
<input type="text" name="s" class="query live-search-query" value="" placeholder="Search..." />
<button class="search-button" type="submit"><i class="fa fa-search"></i></button>
</form>
</div> 
</section>
</div>
</div>
<div id="main-head" class="main-head">
<div class="wrap">
<header class="default">
<div class="title">
<a href="https://www.forexcrunch.com/" title="Forex Crunch" rel="home" class">
<img src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2011/01/forexcrunch.png" class="logo-image" alt="Forex Crunch" />
</a> </div>
<div class="right">
<div class="textwidget"><div id="div-gpt-ad-1452597627604-0"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1452597627604-0'); });
</script></div>
</div>
</div>
</header>
<div class="navigation-wrap cf" data-sticky-nav="1" data-sticky-type="smart">
<nav class="navigation cf nav-dark">
<div class>
<div class="mobile" data-type="classic" data-search="1">
<a href="#" class="selected">
<span class="text">Navigate</span><span class="current"></span> <i class="hamburger fa fa-bars"></i>
</a>
</div>
<div class="menu-forex-menu-container"><ul id="menu-forex-menu" class="menu"><li id="menu-item-12244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-12244"><a title="About Forex Crunch" href="https://www.forexcrunch.com/about/">About</a>
<ul class="sub-menu">
<li id="menu-item-13023" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13023"><a href="https://www.forexcrunch.com/about/">About</a></li>
<li id="menu-item-12250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12250"><a href="https://www.forexcrunch.com/the-team/">The Forex Crunch Team</a></li>
<li id="menu-item-12249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12249"><a href="https://www.forexcrunch.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-21008" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-21008"><a href="https://www.forexcrunch.com/forex-tools/">Tools</a>
<ul class="sub-menu">
<li id="menu-item-20989" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20989"><a href="https://www.forexcrunch.com/forex-tools/">Forex Tools</a></li>
<li id="menu-item-44574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44574"><a href="https://www.forexcrunch.com/tips-for-forex-traders/">Tips for Forex Traders</a></li>
<li id="menu-item-19122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-3 menu-item-19122"><a href="https://www.forexcrunch.com/category/forex-basics/">Basics</a></li>
<li id="menu-item-36252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36252"><a href="https://www.forexcrunch.com/forex-conventions/">Forex Conventions</a></li>
</ul>
</li>
<li id="menu-item-12248" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-cat-53 menu-item-12248"><a title="Forex News" href="https://www.forexcrunch.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-13021" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-53 menu-item-13021"><a href="https://www.forexcrunch.com/category/news/">Forex News</a></li>
<li id="menu-item-14045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-38 menu-item-14045"><a href="https://www.forexcrunch.com/category/opinions/">Opinions</a></li>
<li id="menu-item-13022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-1051 menu-item-13022"><a href="https://www.forexcrunch.com/category/forex-industry-2/">Forex Industry</a></li>
<li id="menu-item-13016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-1003 menu-item-13016"><a href="https://www.forexcrunch.com/category/forex-bits/">Forex Bits</a></li>
</ul>
</li>
<li id="menu-item-13007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-21 menu-item-13007"><a href="https://www.forexcrunch.com/category/daily-analysis/">Daily</a></li>
<li id="menu-item-13013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-422 menu-item-13013"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/">Weekly Forecasts</a>
<ul class="sub-menu">
<li id="menu-item-77545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77545"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/us-dollar-forecast/">Major Events Outlook</a></li>
<li id="menu-item-77542" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77542"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/eur-usd-outlook/">EUR/USD forecast</a></li>
<li id="menu-item-77543" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77543"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/gbp-usd-outlook/">GBP/USD Forecast</a></li>
<li id="menu-item-77546" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77546"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/usd-jpy-forecast/">USD/JPY Forecast</a></li>
<li id="menu-item-77544" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77544"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/aud-usd-outlook/">AUD/USD Forecast</a></li>
<li id="menu-item-77547" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77547"><a href="https://www.forexcrunch.com/category/forex-weekly-outlook/usd-cad-outlook/">USD/CAD Forecast</a></li>
</ul>
</li>
<li id="menu-item-19120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19120"><a href="https://www.forexcrunch.com/live-forex-calendar/">Live Calendar</a></li>
<li id="menu-item-66039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66039"><a href="https://www.forexcrunch.com/subscribe/">Subscribe</a></li>
</ul></div>
</div>
</nav>
</div>
</div>
</div>
<div class="breadcrumbs-wrap">
<div class="wrap">
<div class="breadcrumbs"><span class="location">You are at:</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.forexcrunch.com/"><span itemprop="title">Home</span></a></span><span class="delim">&raquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.forexcrunch.com/category/news/"><span itemprop="title">Forex News</span></a></span><span class="delim">&raquo;</span><span class="current">GBP/USD suffers altitude sickness, new Powell-powered rally may wait</span></div> </div>
</div>
<div class="main wrap cf">
<div class="row">
<div class="col-8 main-content">
<article id="post-228305" class="post-228305 post type-post status-publish format-standard has-post-thumbnail category-news title-above">
<header class="post-header cf">
<div class="heading cf">
<h1 class="post-title item fn" itemprop="name headline">
GBP/USD suffers altitude sickness, new Powell-powered rally may wait </h1>
<a href="https://www.forexcrunch.com/gbp-usd-suffers-altitude-sickness-new-powell-powered-rally-may-wait/#respond" class="comments"><i class="fa fa-comments-o"></i> 0</a>
</div>
<div class="post-meta cf">
<span class="posted-by">By
<span class="reviewer" itemprop="author"><a href="https://www.forexcrunch.com/author/admin-3/" title="Posts by Yohay Elam" rel="author">Yohay Elam</a></span>
</span>
<span class="posted-on">
<span class="dtreviewed">
Published:
<time class="value-title" datetime="2021-02-24T13:08:59+01:00" title="Feb 24, 2021 12:08" itemprop="datePublished">Feb 24, 2021 12:08 GMT | </time>
Last Modified:
<time class="value-title" datetime="2021-02-24T13:08:59+01:00" title="Feb 24, 2021 13:08" itemprop="dateModified">Feb 24, 2021 13:08 GMT</time>
</span>
</span>
<span class="cats"><a href="https://www.forexcrunch.com/category/news/" rel="category tag">Forex News</a></span>
</div>
</header>
<div class="post-container cf">
<div class="post-content-right">

<div id='div-gpt-ad-1447926288576-0' style='height:250px; width:300px;float:left; margin: 20px; position:relative;z-index:1;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1447926288576-0'); });
</script>
</div>
<div class="post-content description " itemprop="articleBody">
<ul>
<li><strong>GBP/USD has tumbled over 100 pips from the highs after a massive rally. </strong></li>
<li><strong>Fed Chair Powell´s dovishness and the UK´s exit plan may trigger a new upward move after the correction ends.</strong></li>
<li><strong>Wednesday&#8217;s four-hour chart is showing the currency pair is still suffering from overbought conditions.</strong></li>
</ul>
<p><strong>Overheating requires a quick cooldown</strong> – not <a href="https://www.fxstreet.com/economic-calendar/united-states" data-cke-saved-href="https://www.fxstreet.com/economic-calendar/united-states">US</a> inflation, but rather GBP/USD&#8217;s rally. Jerome Powell, Chairman of the Federal Reserve, has pushed the dollar down by promising ongoing support to the economy. This &#8220;Powell Put&#8221; for stocks also contributed to propelling the pound to sky-high levels of 1.4240, last seen nearly three years ago. The reality check has come now.</p>
<p>Sterling&#8217;s upside move was also underpinned by <strong>speculation that the UK may accelerate its exit from restrictions</strong> before the government&#8217;s June 21 target date. Reports by the British press have yet to be confirmed – and will likely turn into nothing.</p>
<p>Quick vaccine-led recovery in Britain also led some market <strong>participants to bet on the Bank of England raising rates</strong> sooner rather than later. Similar to hiking borrowing costs in America, UK bond yields signaled an early move in response to higher inflation expectations. However, BOE Governor Andrew Bailey and his colleagues – slated for public appearances on Thursday – will likely play down any such move.</p>
<p><strong>Bloated estimates about Britain&#8217;s bounceback</strong> are behind the fall, but the picture remains positive for sterling as the vaccination campaign continues at full speed.</p>
<p>Back to the US, <strong>Powell appears before Congress</strong> again on Wednesday and will likely reiterate that the Fed &#8220;is not thinking about thinking of raising rates&#8221; as he once said. Stressing that ten million Americans remain unemployed and that the Fed is there to keep long-term borrowing costs low should alleviate markets. For the dollar, while ten-year Treasury yields hold below 1.50%, the dollar&#8217;s gains will likely be limited.</p>
<p>See <a href="https://www.fxstreet.com/analysis/dollar-tumbles-as-powell-says-no-rate-hike-no-taper-202102232234" target="_blank" rel="noopener noreferrer" data-cke-saved-href="https://www.fxstreet.com/analysis/dollar-tumbles-as-powell-says-no-rate-hike-no-taper-202102232234">Dollar tumbles as Powell says no rate hike, no taper</a></p>
<p>Investors will also be awaiting stimulus news. The House is set to approve the $1.9 trillion bill on Friday but the real battle is in the Senate. Any comments from members in the upper chamber may rock markets.</p>
<p>All in all, once the correction is over, <a href="https://www.fxstreet.com/currencies/gbpusd" data-cke-saved-href="https://www.fxstreet.com/currencies/gbpusd">GBP/USD</a> has room to rise.</p>
<h2 class="fxs_headline_medium">GBP/USD Technical analysis</h2>
<p><a href="https://editorial.fxstreet.com/miscelaneous/f1tg78Nt8cKAuwa32Bjz9rG1TXY2d04olNXN7tGY/GBP_USD%20-%202021-02-24T125854.391-637497647389715438.png" target="_blank" rel="noopener noreferrer" data-cke-saved-href="https://editorial.fxstreet.com/miscelaneous/f1tg78Nt8cKAuwa32Bjz9rG1TXY2d04olNXN7tGY/GBP_USD%20-%202021-02-24T125854.391-637497647389715438.png"><img src="https://editorial.fxstreet.com/miscelaneous/f1tg78Nt8cKAuwa32Bjz9rG1TXY2d04olNXN7tGY/GBP_USD%20-%202021-02-24T125854.391-637497647389715438.png" data-cke-saved-src="https://editorial.fxstreet.com/miscelaneous/f1tg78Nt8cKAuwa32Bjz9rG1TXY2d04olNXN7tGY/GBP_USD%20-%202021-02-24T125854.391-637497647389715438.png" /></a></p>
<p>The <strong>Relative Strength Index on the four-hour chart is still above 70</strong> – indicating overbought conditions but below extreme levels seen earlier. Other <a href="https://www.fxstreet.com/rates-charts/indicators" data-cke-saved-href="https://www.fxstreet.com/rates-charts/indicators">indicators</a> such as momentum and cable&#8217;s trading above the 50, 100 and 200 Simple Moving Averages are pointing down.</p>
<p>Support awaits at 1.4095, a temporary cap on the way up, and then by 1.4050, a support line seen earlier this week. Further below 1.3970 and 1.3950 are the next levels to watch.</p>
<p>Resistance is at 1.42, the round number, and then the new 2021 peak of 1.4240. The next lineup high is 1.43.</p>
<p>More  <a href="https://www.fxstreet.com/analysis/five-factors-moving-the-us-dollar-in-2021-and-not-necessarily-to-the-downside-202101051208" target="_blank" rel="noopener noreferrer" data-cke-saved-href="https://www.fxstreet.com/analysis/five-factors-moving-the-us-dollar-in-2021-and-not-necessarily-to-the-downside-202101051208">Five factors moving the US dollar in 2021 and not necessarily to the downside</a></p>
<a data-sumome-listbuilder-id="6d1d114d-150b-4330-9a4e-fa2b436a5859">Get the 5 most predictable currency pairs</a>
</div>
</div>
</div>
</article>
<section class="navigate-posts">
<div class="previous"><span class="main-color title"><i class="fa fa-chevron-left"></i> Previous Article</span><span class="link"><a href="https://www.forexcrunch.com/eur-jpy-price-analysis-next-stop-at-129-00-and-beyond/" rel="prev">EUR/JPY Price Analysis: Next stop at 129.00 and beyond</a></span> </div>
<div class="next"><span class="main-color title">Next Article <i class="fa fa-chevron-right"></i></span><span class="link"><a href="https://www.forexcrunch.com/gbp-usd-has-room-to-rise-once-the-correction-is-over/" rel="next">GBP/USD has room to rise once the correction is over</a></span> </div>
</section>
<h3 class="section-head">About Author</h3>
<section class="author-info">
<img alt='' src='https://secure.gravatar.com/avatar/1c105436c960aeacb81d4f580c18865b?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1c105436c960aeacb81d4f580c18865b?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />
<div class="description">
<a href="https://www.forexcrunch.com/author/admin-3/" title="Posts by Yohay Elam" rel="author">Yohay Elam</a>
<ul class="social-icons">
<li>
<a href="https://www.forexcrunch.com" class="icon fa fa-home" title="Website">
<span class="visuallyhidden">Website</span></a>
</li>
</ul>
<p class="bio"><strong>Yohay Elam – Founder, Writer and Editor</strong>
I have been into forex trading for over 5 years, and I share the experience that I have and the knowledge that I’ve accumulated. After taking a short course about forex. Like many forex traders, I’ve earned a significant share of my knowledge the hard way. Macroeconomics, the impact of news on the ever-moving currency markets and trading psychology have always fascinated me.
Before founding Forex Crunch, I’ve worked as a programmer in various hi-tech companies. I have a B. Sc. in Computer Science from Ben Gurion University. Given this background, forex software has a relatively bigger share in the posts.
<a href="https://plus.google.com/u/1/112509878330587949772/about" rel="author">Yohay's Google Profile</a></p>
</div>
</section>
<div class="comments">
<div id="disqus_thread"></div>
</div>
</div>
<aside class="col-4 sidebar">
<ul>
<li id="text-506661927" class="widget widget_text"> <div class="textwidget">

<div id='div-gpt-ad-1461582647220-0' style='height:160px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1461582647220-0'); });
</script>
</div>
</div>
</li>
<li id="text-506661920" class="widget widget_text"> <div class="textwidget"><p><br />
</p>
<div id="div-gpt-ad-1448298071147-0" style="height: 600px; width: 300px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1448298071147-0'); });
</script></div>
<p>&nbsp;</p>
<h3>Top Brokers</h3>
<p></p>
<div id="div-gpt-ad-1536052130018-0" style="height: 35px; width: 310px;"><script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1536052130018-0'); });
</script></div>
<p></p>
<div id="div-gpt-ad-1541506869475-0" style="height: 400px; width: 300px;"><script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1541506869475-0'); });
</script></div>
<p><br />
<br />
</p>
<div id="div-gpt-ad-1449138542534-1" style="height: 33px; width: 100px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1449138542534-1'); });
</script></div>
<p></p>
<div id="div-gpt-ad-1449138542534-2" style="height: 33px; width: 100px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1449138542534-2'); });
</script></div>
<p></p>
<div id="div-gpt-ad-1449138542534-3" style="height: 33px; width: 100px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1449138542534-3'); });
</script></div>
<p></p>
<div id="div-gpt-ad-1449138542534-4" style="height: 33px; width: 100px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1449138542534-4'); });
</script></div>
<p></p>
<div id="div-gpt-ad-1449138542534-5" style="height: 33px; width: 100px;"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1449138542534-5'); });
</script></div>
<p>&nbsp;</p>
<div id="FJ-voice-news-player" style="width:300px"></div>
<p><br />
<script type='text/javascript'>
    (function () {
        var jo = document.createElement('script');
        jo.type = 'text/javascript';
        jo.id = 'FJVoiceFeed';
        var r = Math.floor(Math.random() * (9999 - 0 + 1) + 0);
        jo.src = 'https://www.financialjuice.com/widgets/voice-player.js?mode=inline&display=1&container=FJ-voice-news-player&info=forexcrunch&r=' + r;
        document.getElementsByTagName('head')[0].appendChild(jo);
    })();
</script></p>
</div>
</li>
<li id="text-506661919" class="widget widget_text"><h3 class="widgettitle">About ForexCrunch</h3> <div class="textwidget"><p>Forex Crunch is a site all about the foreign exchange market, which consists of news, opinions, daily and weekly forex analysis, technical analysis, tutorials, basics of the forex market, forex software posts, insights about the forex industry and whatever is related to Forex.</p>
<p><a href="https://www.forexcrunch.com/about/">Read More</a></p>
</div>
</li>
<li id="text-506661921" class="widget widget_text"><h3 class="widgettitle">Follow us</h3> <div class="textwidget"><div id="FJ-voice-news-player" style="width:300px"></div>

<script type='text/javascript'>
    (function () {
        var jo = document.createElement('script');
        jo.type = 'text/javascript';
        jo.id = 'FJVoiceFeed';
        var r = Math.floor(Math.random() * (9999 - 0 + 1) + 0);
        jo.src = 'https://www.financialjuice.com/widgets/voice-player.js?mode=inline&display=1&container=FJ-voice-news-player&info=forexcrunch&r=' + r;
        document.getElementsByTagName('head')[0].appendChild(jo);
    })();
</script>
<div><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-facebook nolightbox" data-provider="facebook" target="_blank" rel="nofollow noopener noreferrer" title="Follow us on Facebook" href="https://www.facebook.com/Forex-Crunch-239940099600/" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:21px;margin-right:21px;"><img alt="Facebook" title="Follow us on Facebook" class="synved-share-image synved-social-image synved-social-image-follow" width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/facebook.png" /></a><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-twitter nolightbox" data-provider="twitter" target="_blank" rel="nofollow noopener noreferrer" title="Follow us on Twitter" href="https://twitter.com/forexcrunch" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:21px;margin-right:21px;"><img alt="twitter" title="Follow us on Twitter" class="synved-share-image synved-social-image synved-social-image-follow" width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/twitter.png" /></a><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-google_plus nolightbox" data-provider="google_plus" target="_blank" rel="nofollow noopener noreferrer" title="Follow us on Google+" href="https://plus.google.com/101790667780688710947/posts" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:21px;margin-right:21px;"><img alt="google_plus" title="Follow us on Google+" class="synved-share-image synved-social-image synved-social-image-follow" width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/google_plus.png" /></a><a class="synved-social-button synved-social-button-follow synved-social-size-64 synved-social-resolution-single synved-social-provider-mail nolightbox" data-provider="mail" rel="nofollow" title="Contact Us" href="https://www.forexcrunch.com/contact-us/" style="font-size: 0px; width:64px;height:64px;margin:0;margin-bottom:21px;"><img alt="mail" title="Contact Us" class="synved-share-image synved-social-image synved-social-image-follow" width="64" height="64" style="display: inline; width:64px;height:64px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/plugins/social-media-feather/synved-social/image/social/regular/128x128/mail.png" /></a></div>
<a href="http://www.financialjuice.com/company/Forex%20Crunch" rel="nofollow noopener noreferrer" target="_blank"><img src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/uploads/2016/05/FinancialJuice.png"></a>
<br />

<div id='div-gpt-ad-1448015589645-0' style='height:150px; width:150px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1448015589645-0'); });
</script>
</div>
</div>
</li>
</ul>
</aside>
</div> 
</div> 
<footer class="main-footer">
<div class="wrap">
<ul class="widgets row cf">
<li class="widget col-4 widget_nav_menu"><h3 class="widgettitle">Useful Links</h3><div class="menu-useful-links-container"><ul id="menu-useful-links" class="menu"><li id="menu-item-65795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65795"><a href="https://www.forexcrunch.com/about/">About</a></li>
<li id="menu-item-65796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65796"><a href="https://www.forexcrunch.com/the-team/">The Forex Crunch Team</a></li>
<li id="menu-item-65797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65797"><a href="https://www.forexcrunch.com/contact-us/">Contact Us</a></li>
<li id="menu-item-65798" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65798"><a href="https://www.forexcrunch.com/advertising-on-forex-crunch/">Advertising</a></li>
<li id="menu-item-65800" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65800"><a href="https://www.forexcrunch.com/forex-tools/">Forex Tools</a></li>
</ul></div></li> <li class="widget col-4 widget_recent_entries"> <h3 class="widgettitle">Recent Updates</h3> <ul>
<li>
<a href="https://www.forexcrunch.com/chainlink-price-prediction-link-remains-bullish-despite-short-term-sell-off-as-whales-hold-strong/">Chainlink Price Prediction: LINK remains bullish despite short-term sell-off as whales hold strong</a>
</li>
<li>
<a href="https://www.forexcrunch.com/fomc-chairman-jerome-powell-testimony-before-house-committee-on-financial-services-live-stream/">FOMC Chairman Jerome Powell testimony before House Committee on Financial Services – live stream</a>
</li>
<li>
<a href="https://www.forexcrunch.com/boes-broadbent-sterling-appreciation-to-have-some-depressive-effect-on-inflation/">BoE&#8217;s Broadbent: Sterling appreciation to have some depressive effect on inflation</a>
</li>
<li>
<a href="https://www.forexcrunch.com/boes-bailey-eu-locality-policy-for-financial-services-is-controversial/">BoE&#8217;s Bailey: EU locality policy for financial services is controversial</a>
</li>
<li>
<a href="https://www.forexcrunch.com/gold-price-analysis-break-below-1760-to-leave-xau-usd-under-pressure-commerzbank/">Gold Price Analysis: Break below $1760 to leave XAU/USD under pressure – Commerzbank</a>
</li>
</ul>
</li><li class="widget col-4 widget_text"><h3 class="widgettitle">Disclaimer</h3> <div class="textwidget"><p style="font-size: 10px">Foreign exchange (Forex) trading carries a high level of risk and may not be suitable for all investors. The risk grows as the leverage is higher. Investment objectives, risk appetite and the trader's level of experience should be carefully weighed before entering the Forex market. There is always a possibility of losing some or all of your initial investment / deposit, so you should not invest money which you cannot afford to lose. The high risk that is involved with currency trading must be known to you. Please ask for advice from an independent financial advisor before entering this market. Any comments made on Forex Crunch or on other sites that have received permission to republish the content originating on Forex Crunch reflect the opinions of the individual authors and do not necessarily represent the opinions of any of Forex Crunch's authorized authors. Forex Crunch has not verified the accuracy or basis-in-fact of any claim or statement made by any independent author: Omissions and errors may occur. Any news, analysis, opinion, price quote or any other information contained on Forex Crunch and permitted re-published content should be taken as general market commentary. This is by no means investment advice. Forex Crunch will not accept liability for any damage, loss, including without limitation to, any profit or loss, which may either arise directly or indirectly from use of such information. </p></div>
</li> </ul>
</div>
<div class="lower-foot">
<div class="wrap">
</div>
</div>
</footer>
</div> 
<script type='text/javascript'>
/* <![CDATA[ */
/* disqus_count */
var countVars = {"disqusShortname":"forexcrunch"};
/* disqus_embed */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"228305 https:\/\/www.forexcrunch.com\/?p=228305","disqusShortname":"forexcrunch","disqusTitle":"GBP\/USD suffers altitude sickness, new Powell-powered rally may wait","disqusUrl":"https:\/\/www.forexcrunch.com\/gbp-usd-suffers-altitude-sickness-new-powell-powered-rally-may-wait\/","postId":"228305"};
/* bunyad-theme */
var Bunyad = {"ajaxurl":"https:\/\/www.forexcrunch.com\/wp-admin\/admin-ajax.php"};

/* ]]> */
</script>
<script type="text/javascript" src="https://forexcrunch-wpengine.netdna-ssl.com/wp-content/cache/scripts/227a4f1bc4779f020a103fe28901a1eb-minify.js">/*Cache!*/</script>
<script type="text/javascript" src="/roadblock/interstitial.js">

/***********************************************
* Interstitial Content Box- (c) Dynamic Drive DHTML code library (www.dynamicdrive.com)
* Please keep this notice intact
* Visit Dynamic Drive at http://www.dynamicdrive.com/ for full source code
***********************************************/

</script>
</body>
</html>